Mustang GT350 Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hello all,

I drive a ‘17 GT350 with about 38,000 miles. I purchased the car in February and first time taking it out of town, the car started acting weird about 30 minutes into the trip. It started to go limp every 5 seconds or so, felt a slight lag or rev match/limp mode that would continue. Then the wrench icon lit up on the dash, followed by “hill assist not available.” Also, the cruise control would no longer engage. After the car is turned off and then turned back on, the icons are gone and the issue comes and goes maybe once or twice a week (I work about 15 miles from home so sometimes it happens on the freeway and sometimes it does not). The car was taken to the dealer twice after the lights came on and both times the said they ran the scanner for codes but found nothing. I’ve seen other posts on this forum and other sites as well but haven’t come across one in which the problem was identified and/or fixed. I’ve read it could be the throttle body or something to do with the clutch sensors. Others have said a simple battery disconnect has “fixed” the issue for them as well.
So with all that said, has anyone else experience this issue and gotten it diagnosed/fixed?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
One of two clutch switches or wheel speed sensor. Dealt with both with similar issues and no codes. Check your top of travel switch and clutch bottom of travel switches for loosening or lack of spring return when depressed or released. I first found a copper relay contact in my floor after my switch disintegrated but the internal spring can also fail.

Wheel speed sensor indicated left rear was turning substantially faster than others, especially when car was sitting still, and caused lurching limp mode situation. Disconnected battery and it would clear, then 2-3 miles later would return.
Thank you so much for the response. It’s been an issue I couldn’t figure out. Did fixing/replacing the things you mentioned erase the issue? I’m going to check these things out on my next day off!
 
1 - 3 of 3 Posts
Top