Mustang GT350 Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Well after paying big bucks to run an open track day at Daytona tomorrow, disappointment this morning. After putting the car on jack stands to do a pre-race check list, I found my left rear wheel to be loose and wobbly. Re checked lug nuts, removed wheel and found the hub/bearing was what was wobbling. None of the local Ford dealers had the part or could get the car in. Wouldn't give me a hub to replace myself under warranty. So I have to miss my Daytona track day. Very disappointed to say the least. Thought about running anyway, but not worth the chance at 150mph. Only 2200 miles on the car. But I still love to drive the beast.
 

·
Registered
Joined
·
141 Posts
Disappointing for sure but glad you did the inspection. It might have saved your life. There will always be another track day.
 

·
Registered
Joined
·
59 Posts
Well after paying big bucks to run an open track day at Daytona tomorrow, disappointment this morning. After putting the car on jack stands to do a pre-race check list, I found my left rear wheel to be loose and wobbly. Re checked lug nuts, removed wheel and found the hub/bearing was what was wobbling. None of the local Ford dealers had the part or could get the car in. Wouldn't give me a hub to replace myself under warranty. So I have to miss my Daytona track day. Very disappointed to say the least. Thought about running anyway, but not worth the chance at 150mph. Only 2200 miles on the car. But I still love to drive the beast.
Geez, good thing you did a thorough pre-check! This is a good reminder for everyone to take the same precautions. Is this type of premature hub failure a known problem?

Stay safe out there!
 

·
Registered
Joined
·
502 Posts
Well after paying big bucks to run an open track day at Daytona tomorrow, disappointment this morning. After putting the car on jack stands to do a pre-race check list, I found my left rear wheel to be loose and wobbly. Re checked lug nuts, removed wheel and found the hub/bearing was what was wobbling. None of the local Ford dealers had the part or could get the car in. Wouldn't give me a hub to replace myself under warranty. So I have to miss my Daytona track day. Very disappointed to say the least. Thought about running anyway, but not worth the chance at 150mph. Only 2200 miles on the car. But I still love to drive the beast.
Wow, good catch. Lucky you didn’t let that slip by. Guess we all should be making these regular checks.

Still waiting for a track day, soon I hope.
 

·
Registered
Joined
·
757 Posts
Ditto, glad they found it BEFORE you had issues!! Be interested to hear what the diagnosis is once they have looked at everything, i.e., did a bearing fail or did the hub bolt loosen up somehow?
 

·
Registered
Joined
·
65 Posts
Bad timing for sure, but at least you found it before you got on the track. When you get a chance, go back to Daytona. It's a blast to drive and the sound track from that 5.2 is incredible.
 

·
Registered
Joined
·
247 Posts
That's a shame they won't release the part and let you do the work. I had a Ducati that my local dealer just gave me the parts on two or three occasions.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top