Looking for guidance
Close
Login to Your Account
Mustang GT350 Forum

Looking for guidance

This is a discussion on Looking for guidance within the Mustang GT350 Problems and Issues forums, part of the Mustang GT350 Forum category; 2017 Shelby gt350 with 3,000 kilometres on it and is winter stored and during a periodic winter engine starts, the driver mode and exhaust switch ...

Results 1 to 4 of 4
Like Tree1Likes
  • 1 Post By RJay

Thread: Looking for guidance

  1. #1
    Junior Member
    Member #
    10662
    Join Date
    Feb 2020
    Location
    Athabasca, Alberta, Canada
    Posts
    2
    Member #
    10662
    Mentioned
    0 Post(s)

    Looking for guidance

    2017 Shelby gt350 with 3,000 kilometres on it and is winter stored and during a periodic winter engine starts, the driver mode and exhaust switch have failed to operate with an error prompt stating that it is unavailable. Have others experienced this and I am wondering what was done to rectify the situation. Some reading I have done suggests that it might be connected with exhaust valves being stuck?

  2. #2
    Member RJay's Avatar
    Member #
    9400
    Join Date
    May 2019
    Location
    Phoenix
    Posts
    74
    Member #
    9400
    Liked
    16 times
    Mentioned
    0 Post(s)
    Is it on a battery tender? The electronics on these cars will do wonky things when the voltage is low.

    Also, everything I have read on the topic says put her up for the winter and don't start it again until you're ready to drive it in the Spring. Every time you start one of these cars, and fail to bring the entire system up to operating temps, you trap moisture in the exhaust system.
    03reptile likes this.
    2019 GT350 - Finally arrived!
    2014 Mustang GT - Great car! Hard to see her go!
    1965 Mustang Fastback - Wish I still had it!

  3. #3
    Junior Member
    Member #
    8308
    Join Date
    Sep 2018
    Posts
    6
    Member #
    8308
    Liked
    1 times
    Mentioned
    0 Post(s)
    It could be the valves, yes. I have a 2018 GT350 that has had that error message since the car was 3,000 miles old. I'm now up to 8,000
    Ford cannot fix the problem, whatever it is. They will likely buy the car back unfortunately.
    I think it is OK to start the car periodically during the winter as long as you bring it to full operating temperature.

  4. Remove Advertisements
    GT350.org
    Advertisements
     

  5. #4
    Junior Member
    Member #
    10662
    Join Date
    Feb 2020
    Location
    Athabasca, Alberta, Canada
    Posts
    2
    Member #
    10662
    Mentioned
    0 Post(s)
    Hello All
    Thanks Milo and Rjay
    The problem has corrected itself during the last engine start which I did on a milder winter day which was hovering at freezing temperature threshold. I did let run for 15 to 20 minutes and the exhaust valves now function correctly and allows me to change driver modes. Lesson learned here is to not mess with these functions during winter temperatures.
    Regards
    JKE

Home | Forum | Active Topics | What's New

Sponsors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •